Friday, April 19, 2019

Penyebab Dan Cara Mengatasi Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di Android Studio

penyebab dan cara mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 pada android studio

Penyebab dan cara mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio.  Dan juga cara mengatasi error Unable to resolve dependency for ':app@debugAndroidTest/compileClasspath': Could not resolve com.android.support:appcompat-v7:28.0.0-alpha1 di android studio.

Penyebab  Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1

Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1
Gambar Error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1

Banyak juga yang mengeluh setiap melakukan update android studio, pasti ada-ada aja yang bermasalah. Lah saya juga gatau mau bilang apa tentang hal seperti itu, karena saya juga sih merasakan hal yang sama, sampai-sampai teman saya menyarankan gak perlu update-update, entar ada aja yang error.. wkwkw.. kok jadi takut gitu ya.

Tapi tenang, jika kita mengetahui akar masalahnya, pasti bisa diatasi dengan bijak tanpa menjauhkan yang namanya update.

Nah masalah error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 ini biasanya dialami yang baru melakukan update, disitu terlihat ada tambahan “alpha1” di ujung com.android.support:appcompat-v7:28.0.0-alpha1 dimana ini adalah versi updatenya, dan perlu anda ketahui sebelumnya adalah com.android.support:appcompat-v7:28.0.0 tanpa ada alpha1.

Jadi penyebab terjadinya error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio dikarenakan updatenya belum sempurna pada bagian gradle, saya tidak bisa memastikan apakah dari pihak developnya yang salah atau belum sempurna update yang anda lakukan

Bagaimana Solusi Mengatasi Error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio?


Bagi kamu yang sempat mengalami hal tersebut, kamu hanya perlu mengembalikan ke versi sebelumnya atau versi dibawahnya yaitu dengan menghilangkan “alpha1” di ujung com.android.support:appcompat-v7:28.0.0-alpha1.

Bagaimana Caranya?


Untuk mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1, kita harus pergi ke bagian gradle, untuk lebih jelasnya, simak dan perhatikan langkah-langkah berikut ini

Perhatikan pada bagian kiri, lihat menu “Gradle Scripts”, seperti terlihat pada gambar yang dibawah ini yang ditandai dengan warna kuning.

cara mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio dengan mengembalikan ke versi sebelumnya...done..
Gambar Mengatasi Error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1

Kemudian double klik build.gradle(Module:app) seperti yang ditandai dengan warna merah pada gambar diatas, dan akan tampil editor app seperti gambar berikut ini.

solusi mengatasi error di android studio Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1
Gambar Penyebab Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1

Scroll kebawah pada sampai pada bagian dependencies, disinilah akar permasalahan penyebab error error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1,bisa anda perhatikan yang ditandai dengan kota biru pada gambar diatas, ada tambahan “-alpha1” pada bagian ujungnya. 

Ini menjadi penyebab langsung error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 dan error Unable to resolve dependency for ':app@debugAndroidTest/compileClasspath': Could not resolve com.android.support:appcompat-v7:28.0.0-alpha1 di android studio.

Selanjutnya hapus “-alpha1” pada bagian script yang ditandai kotak biru tersebut, sehingga akan seperti gambar berikut ini.

langkah mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio setelah update
Gambar Solusi Mengatasi Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1


Bisa anda perhatikan pada kotak penanda kuning diatas, itulah cara mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio.

Apa Selanjutnya?
Setelah kita selesai mencari penyebab dan cara mengatasi error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio, kita perlu melakukan “Rebuild” atau “Make Project” saja sudah cukup.

Bisa dengan menekan button bericon “Palu” langsung atau melalui menu “Build” seperti gambar berikut ini

lakukan make project untuk menyelesaikan masalah error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1
Gambar Langkah Finish Dalama Mengatasi Error Dependency

Icon palu berguna untuk make project atau seperti Sync Ulang… nah tekan button atau menu atau icon tersebut untuk menyelesaikan permasalahan error Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 di android studio

Demikianlah sedikit panduan tutorial dalam mengetahui penyebab dan cara mengatasi Unable to resolve dependency for 'app@debugcompileClasspath' Could not resolve com.android.supportappcompat-v728.0.0-alpha1 yang secara bersamaan juga mengatasi error Unable to resolve dependency for ':app@debugAndroidTest/compileClasspath': Could not resolve com.android.support:appcompat-v7:28.0.0-alpha1 di android studio.

Semoga artikel ini berguna dan bermanfaat bagi teman-teman yang membutuhkan. Jika ada yang ingin di tanyakan silahkan sampaikan melalui kolom komentar yang sudah disediakan.


EmoticonEmoticon